<!doctype html>
      <html class="single desktop logo-above-nav fixed-full-width" lang="en">
        <head>
          <title data-react-helmet="true">Tom Brady&#x27;s TB12 Brand Launches Podcast on Peak Performance</title>
          <meta data-react-helmet="true" http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta data-react-helmet="true" charset="UTF-8"/><meta data-react-helmet="true" name="instagram_profile" value="thebeet"/><meta data-react-helmet="true" name="description" content="TB12 is launching a new podcast called Keep Going, with CEO John Burns and guests focused on how to reach peak performance with plant-based nutrition."/><meta data-react-helmet="true" name="keywords" content="tb12 podcast, tom brady podcast, tom brady diet, tom brady plant based, tb12 keep going podcast,plant-based athletes,news"/><meta data-react-helmet="true" property="fb:app_id" content="2344390549157794"/><meta data-react-helmet="true" property="fb:admins" content="100002025987268"/><meta data-react-helmet="true" property="og:title" content="Tom Brady&#x27;s TB12 Brand Launches Podcast on Peak Performance"/><meta data-react-helmet="true" property="og:description" content="TB12 is launching a new podcast called Keep Going, with CEO John Burns and guests focused on how to reach peak performance with plant-based nutrition."/><meta data-react-helmet="true" property="og:url" content="https://thebeet.com/tom-bradys-tb12-brand-launches-podcast-on-holistic-health/"/><meta data-react-helmet="true" property="og:site_name" content="The Beet."/><meta data-react-helmet="true" property="og:type" content="article"/><meta data-react-helmet="true" property="og:image" content="https://townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg?w=1200&amp;h=0&amp;zc=1&amp;s=0&amp;a=t&amp;q=89"/><meta data-react-helmet="true" property="og:image:width" content="1200"/><meta data-react-helmet="true" property="og:image:height" content="630"/><meta data-react-helmet="true" name="twitter:card" content="summary_large_image"/><meta data-react-helmet="true" name="twitter:site" content="@thebeetofficial"/><meta data-react-helmet="true" name="sailthru.description" content="TB12 is launching a new podcast called Keep Going, with CEO John Burns and guests focused on how to reach peak performance with plant-based nutrition."/><meta data-react-helmet="true" name="sailthru.date" content="2021-01-12 12:05:27"/><meta data-react-helmet="true" name="sailthru.title" content="Tom Brady’s TB12 Launches Podcast on Peak Performance and Healthy Lifestyle"/><meta data-react-helmet="true" name="sailthru.tags" content="tsmsite-thebeet, tsmmarket-partner-thebeet, tsmtype-partner, plant-based-athletes, news"/><meta data-react-helmet="true" name="sailthru.author" content="maxwellrabb"/><meta data-react-helmet="true" name="sailthru.image.full" content="https://townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg"/><meta data-react-helmet="true" name="sailthru.image.thumb" content="https://townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg"/><meta data-react-helmet="true" http-equiv="Content-Type" content="text/html;charset=UTF-8"/><meta data-react-helmet="true" name="viewport" content="width=1286, initial-scale=1.0"/><meta data-react-helmet="true" name="robots" content="max-image-preview:large"/>
          <link rel="preload" href="/styles/desktop/base.css?ver=506a1ae6887e6e598b04eb8cd1d8514706ac2c03&mver=764" as="style"/>
          <link data-react-helmet="true" id="design-fav" rel="shortcut icon" href="https://townsquare.media/site/959/files/2019/09/beet-favicon-circle.png"/><link data-react-helmet="true" rel="profile" href="http://gmpg.org/xfn/11"/><link data-react-helmet="true" rel="prev" title="4-Ingredient Recipe: Easy, Delicious Gluten-Free Cinnamon Date Coco Bites" href="https://thebeet.com/4-ingredient-recipe-easy-and-delicious-gluten-free-cinnamon-date-coco-bites/"/><link data-react-helmet="true" rel="next" title="This Chronically Ill Influencer Reduced Her Pain With a Plant-Based Diet" href="https://thebeet.com/this-chronically-ill-influencer-reduced-her-pain-with-a-plant-based-diet/"/><link data-react-helmet="true" rel="canonical" href="https://thebeet.com/tom-bradys-tb12-brand-launches-podcast-on-holistic-health/"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" href="https://townsquare.media/site/959/files/2019/11/thebeet-logo-57.png"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="114x114" href="https://townsquare.media/site/959/files/2019/11/thebeet-logo-114.png"/><link data-react-helmet="true" rel="apple-touch-icon-precomposed" sizes="72x72" href="//townsquare.media/site/959/files/2019/11/thebeet-logo-72.png"/>
          <link href="//fonts.googleapis.com/css?family=Roboto:400,400italic,500,500italic,700,300italic,300|Roboto+Condensed:300,400,700&display=swap" rel="stylesheet" type="text/css" />
          <link href="/styles/desktop/base.css?ver=506a1ae6887e6e598b04eb8cd1d8514706ac2c03&mver=764" rel="stylesheet" type="text/css" />
          <script>window.TSM = window.TSM ||{}; window.TSM.fn = window.TSM.fn || {}; window.TSM.fn.isIe = function(n){var t,i;return(n=n||"",!n||n===null||typeof n=="undefined"||n&&!n.match)?!1:(t=n.match(/MSIEs([d.]+)/i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):(t=n.match(/Trident.*rv[ :]*(11)./i),t&&t.length)?(i=parseInt(t[1],10),{className:"ie ie"+i}):!1};
      window.TSM.fn.getFile=function(n,t={},i=document.body){return new Promise(function(r){var e=function(n){n.target.removeEventListener("load",e);r(n.target)},u=document.createElement("script"),f;u.addEventListener("load",e);u.src=n;for(f in t)u.setAttribute(f,t[f]);i.appendChild(u)})};
    </script>
          <script>window.taskQ=[];</script>
          
        <script type="text/javascript">
          window.TSM = window.TSM || {q:[]};
          window.TSM.abgroup = "A";
          window.TSM.cadata = {"activeDomain":"thebeet.com","blogId":959,"method":"get_single","postId":53252,"postType":"post","postDateGmt":"2021-01-12 17:05:27.000+0000"};
          window.TSM.startload = new Date().getTime();
        </script>
          <script>
    (function () {
      function getCookie(name) {
        var value = "; " + document.cookie;
        var parts = value.split("; " + name + "=");
        if (parts.length == 2) return parts.pop().split(";").shift();
      }
      function updateCookie(name, value, expireDays) {
        let d = new Date();
        d.setTime(d.getTime() + (60*60*24*expireDays*1000));
        var expires = "expires="+ d.toUTCString();
        document.cookie = name + "=" + value + ";" + expires + ";path=/";
      }
      window.TSM = window.TSM || {};
      if (window.TSM.abgroup) {
        updateCookie("abgroup", window.TSM.abgroup, 90);
      }

      var xhr = new XMLHttpRequest();
      xhr.open("POST", "/rest/high/api/cogitoergosum", true);
      var cogitoergosum = getCookie("cogitoergosum");
      var abgroup = getCookie("abgroup");
      if (cogitoergosum) {
        window.TSM.cogitoergosum = JSON.parse( atob( decodeURIComponent( cogitoergosum ) ) );
      }
      xhr.onreadystatechange = function() {//Call a function when the state changes.
        if(xhr.readyState == XMLHttpRequest.DONE && xhr.status == 200) {
          if (xhr.response) {
            var result = JSON.parse(xhr.response);
            if (result && result.result) {
              if (result.result.cookie) {
                window.TSM.cogitoergosum = JSON.parse( atob( result.result.cookie ) );
              }
              if (result.result.credentials) {
                window.TSM.credentials = JSON.parse( atob( result.result.credentials ) );
              }
              // console.log("cogitoergosum xhr", window.TSM.cogitoergosum);
            }
          }
        }
      };
      xhr.setRequestHeader("Content-type", "application/json");
      var cadata = window.TSM.cadata || {};
      cadata.experimentGroup = window.TSM.abgroup;
      cadata.viewType = "standard";
      cadata.timespent = new Date().getTime() - window.TSM.startload;
      var referrer = document.referrer;
      var sendData = {
        type: "pageview",
        referrer: referrer,
        url: document.location.href,
        queryParam: document.location.queryParam,
        pageData: cadata,
        scrollPageIndex: 0
      };
      xhr.send(JSON.stringify(sendData));
    }());
  </script>
          <script>
            (function(w){
              w.ga=w.ga||function(){(ga.q=ga.q||[]).push(arguments)};ga.l=+new Date;
              var gaInitData = {"hitType":"pageview","dimension1":"maxwellrabb","dimension2":"news","dimension3":"plant-based-athletes","dimension4":"post","dimension5":"Tue Jan 12 2021","dimension6":"12:012","dimension7":"standard","dimension8":"1312","dimension9":"A","dimension10":"no","dimension12":"","dimension13":""};
gaInitData.dimension13=function(){let refData=sessionStorage.getItem("itemRef"),str=[];return refData&&(refData=JSON.parse(refData),refData.title&&(str.push(refData.title),str.push(refData.source||"NA")),sessionStorage.removeItem("itemRef")),str.join(" -|- ");}();
window.globalDimensionData = {"dimension1":"maxwellrabb","dimension2":"news","dimension3":"plant-based-athletes","dimension4":"post","dimension5":"Tue Jan 12 2021","dimension6":"12:012","dimension7":"standard","dimension8":"1312","dimension9":"A","dimension10":"no","dimension12":"","dimension13":""};
ga( "create", {
          trackingId:"UA-148332019-1",
          name: "primary",
          allowAnchor: false
        });
        ga( "primary.require", "displayfeatures" );
        ga( "primary.require", "outboundLinkTracker", {fieldsObj: window.globalDimensionData} );
        ga( "primary.send", gaInitData );
        window.TSM = window.TSM || {};
        window.TSM.trackersByNameAll = window.TSM.trackersByNameAll || {};
        window.TSM.trackersByNameAll[ "primary" ] = {gaid:"UA-148332019-1"};
            })(window);
          </script>
          <script async src="https://www.google-analytics.com/analytics.js"></script>
          <script async src="//townsquare.media/public/resources/js/autotrack.carbon.js"></script>
          <script>(function(w){
      w.dataLayer = [{"title":"Tom Brady's TB12 Brand Launches Podcast on Peak Performance","callsign":"BEET","market":"National","sitetype":"Partner","siteClassification":"Partner","state":"NY","genre":"misc","pageType":"post","tags":"plant-based-athletes","categories":"news","mediaType":"none"}];
      w.dataLayer[0].referer = document.referrer;w.dataLayer[0].curatedReferer = document.referrer.replace( /https?:\/\//, "" );w.dataLayer[0].dayOfWeek = function(n){return n.toLocaleString("en-US",{weekday:"long"})}(new Date);w.dataLayer[0].periodOfDay = function(n,t,i){t=n.getHours(),i=n.getMinutes(),i<10&&(i="0"+i);var r=parseInt(t+""+i);return r>=0&&r<600?"Overnight":r>=600&&r<1e3?"Morning Drive":r>=1e3&&r<1500?"Midday":r>=1500&&r<1900?"Afternoon Drive":r>=1900&&r<2400?"Evening":void 0}(new Date);
    })(window);</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({"gtm.start": new Date().getTime(),event:"gtm.js"});var f=d.getElementsByTagName(s)[0], j=d.createElement(s),dl=l!="dataLayer"?"&l="+l:"";j.async=true;j.src= "https://www.googletagmanager.com/gtm.js?id="+i+dl;f.parentNode.insertBefore(j,f); })(window,document,"script","dataLayer","GTM-K346HJZ");});</script>
          
          
          
          
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
      (function (d, t) {
        var g = d.createElement(t), s = d.getElementsByTagName(t)[0];
        g.type='text/javascript';
        g.async = true;
        g.defer = true;
        g.src = '//btloader.com/tag?o=5642230212591616&upapi=true';
        s.parentNode.insertBefore(g, s)
      }(document, 'script'));
    });</script>
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        window.TSM.fn.getFile("//action.dstillery.com/orbserv/nsjs?adv=cl1016361&ns=3141&nc=BEET&ncv=24");
      });</script>
          
          
          <script>window.taskQ=window.taskQ||[];window.taskQ.push(function(){
        var _comscore = _comscore || [];
        _comscore.push({ c1: "2", c2: "6665296" });
        (function() {
          var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true; s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
          el.parentNode.insertBefore(s, el);
        })();
      });</script>
          
          <script>//gdpr 2 - tcfapi stub
      ;!function(){var e=function(){var e,t="__tcfapiLocator",a=[],n=window;for(;n;){try{if(n.frames[t]){e=n;break}}catch(e){}if(n===window.top)break;n=n.parent}e||(!function e(){var a=n.document,r=!!n.frames[t];if(!r)if(a.body){var i=a.createElement("iframe");i.style.cssText="display:none",i.name=t,a.body.appendChild(i)}else setTimeout(e,5);return!r}(),n.__tcfapi=function(){for(var e,t=arguments.length,n=new Array(t),r=0;r<t;r++)n[r]=arguments[r];if(!n.length)return a;if("setGdprApplies"===n[0])n.length>3&&2===parseInt(n[1],10)&&"boolean"==typeof n[3]&&(e=n[3],"function"==typeof n[2]&&n[2]("set",!0));else if("ping"===n[0]){var i={gdprApplies:e,cmpLoaded:!1,cmpStatus:"stub"};"function"==typeof n[2]&&n[2](i)}else a.push(n)},n.addEventListener("message",(function(e){var t="string"==typeof e.data,a={};try{a=t?JSON.parse(e.data):e.data}catch(e){}var n=a.__tcfapiCall;n&&window.__tcfapi(n.command,n.version,(function(a,r){var i={__tcfapiReturn:{returnValue:a,success:r,callId:n.callId}};t&&(i=JSON.stringify(i)),e.source.postMessage(i,"*")}),n.parameter)}),!1))};"undefined"!=typeof module?module.exports=e:e()}();</script><script>
      window.cmpFactory = function( varName ) {
        var
          listen = window.attachEvent || window.addEventListener,
          isDebug = RegExp( "debug=([^&]+)" ).exec( location.search );
        listen('message', function(event) {
          window[ varName ].receiveMessage && window[ varName ].receiveMessage(event);
        });

        var commandQueue = [];
        var cmp = function(command, parameter, callback) {
          if( command === "ping" ){
            callback({cmpLoaded: false}, true);
          }else{
            commandQueue.push({
              command: command,
              parameter: parameter,
              callback: callback
            });
          }
        };
        cmp.commandQueue = commandQueue;
        cmp.receiveMessage = function(event) {
          var data = event && event.data && event.data[ varName + "Call" ];
          if (data) {
            commandQueue.push({
              callId: data.callId,
              command: data.command,
              parameter: data.parameter,
              event: event
            });
          }
        };
        cmp.config = {};
        if( isDebug && isDebug[1] && isDebug[1] === "YES" ){
          cmp.config.logging = "debug";
        }
        return cmp;
      };
      window.__cmp = window.cmpFactory( "__cmp" );
      window.__uspapi = window.cmpFactory( "__uspapi" );
    </script><script>
      (function(w) {
        w.TSM.fn.getFile( "//townsquare.media/public/resources/js/cmp.bundle.js", {}, document.head );
        w.cnvr_launcher_options={lid:337};
        w.TSM.fn.getFile( "https://secure.cdn.fastclick.net/js/cnvr-launcher/latest/launcher-stub.min.js", {}, document.head );
      })(window);
    </script>
          <script type="text/javascript" src="//dfm7wh2x5l4za.cloudfront.net/script.js"></script><script async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
        <script>
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        </script>

<script>window.pbjs=window.pbjs||{};window.pbjs.que=window.pbjs.que||[];window.PREBID_TIMEOUT=2000;</script>
<script src="https://cdn.production.townsquareblogs.com/wp-content/uploads/static/prebid/carbon/pb.js?domain=thebeet.com&v=506a1ae6887e6e598b04eb8cd1d8514706ac2c03&mver=764"></script>

<script>(function(){!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
        var params={pubID:"3227",adServer:"googletag",params:{us_privacy: (RegExp( "usprivacy=([^;]+)" ).exec( document.cookie ) || [])[1] || "1---"}};apstag.init(params);})();</script>


<script>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</script>
          <script defer src="https://apis.google.com/js/platform.js"></script>
      <script>window.twttr = (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0],
        t = window.twttr || {};
      if (d.getElementById(id)) return t;
      js = d.createElement(s);
      js.id = id;
      js.src = "https://platform.twitter.com/widgets.js";
      fjs.parentNode.insertBefore(js, fjs);
      t._e = [];
      t.ready = function(f) {
        t._e.push(f);
      };
      return t;
    }(document, "script", "twitter-wjs"));
    (function(d, s, id) {
      var js, fjs = d.getElementsByTagName(s)[0];
      if (d.getElementById(id)) return;
      js = d.createElement(s); js.id = id;
      js.src = "//connect.facebook.net/en_US/sdk.js";
      fjs.parentNode.insertBefore(js, fjs);
    }(document, "script", "facebook-jssdk"));
    !function(f,b,e,v,n,t,s)
    {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
    n.callMethod.apply(n,arguments):n.queue.push(arguments)};
    if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
    n.queue=[];t=b.createElement(e);t.async=!0;
    t.src=v;s=b.getElementsByTagName(e)[0];
    s.parentNode.insertBefore(t,s)}(window, document,'script',
    'https://connect.facebook.net/en_US/fbevents.js');
    fbq('init', '631470830669776');
    fbq('track', 'PageView');</script>
    <script async defer src="//platform.instagram.com/en_US/embeds.js"></script>
    <script>var ZERG = ZERG || {};ZERG.domain = "thebeet.com";ZERG.user = 751;</script>
          <script type="application/ld+json">{"@context":"https://schema.org","@type":"article","headline":"Tom Brady's TB12 Launches Podcast on Peak Performance and Healthy Lifestyle","publisher":{"@type":"Organization","name":"The Beet","logo":{"@type":"ImageObject","url":""}},"url":"https://thebeet.com/tom-bradys-tb12-brand-launches-podcast-on-holistic-health/","mainEntityOfPage":{"@type":"WebPage","@id":"https://thebeet.com/tom-bradys-tb12-brand-launches-podcast-on-holistic-health/"},"description":"TB12 is launching a new podcast called Keep Going, with CEO John Burns and guests focused on how to reach peak performance with plant-based nutrition.","image":"//townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg","author":"Maxwell Rabb","keywords":"maxwellrabb tom-bradys-tb12-brand-launches-podcast-on-holistic-health news plant-based-athletes pagetype-post misc web","datePublished":"2021-01-12T17:05:27.000Z","dateCreated":"2021-01-12T17:05:27.000Z","dateModified":"2021-01-12T19:26:16.000Z"}</script>
        </head>
        <body>
          <div id="fb-root"></div>
          <div id="app"><div><div id="site-menu-wrapper" class="no-showticker"><div class="site-menu-drawer"><ul class="promo-links"><li><a title="Your Guide to Plant-Based Living" href="/welcome-to-the-beet/">Your Guide to Plant-Based Living</a></li><li><a title="28 Day Plant-Based Plan" href="/new-years-resolution-get-healthy-sign-up-for-the-28-day-plant-based-plan/">28 Day Plant-Based Plan</a></li><li><a title="Dessert of the Day" href="/sign-up-for-the-dessert-of-the-day-newsletter-for-healthier-for-you-recipes/">Dessert of the Day</a></li><li><a title="Success Stories" href="/category/first-person/">Success Stories</a></li><li><a title="7 Day Beginner&#x27;s Guide" href="/beginners-guide-to-a-plant-based-diet/">7 Day Beginner&#x27;s Guide</a></li><li><a title="The VegStart Diet" href="/the-vegstart-diet/">The VegStart Diet</a></li></ul></div><div id="site-menu-bg"></div><div class="next-to-logo"><div class="non-menu-content"><a class="logo" href="/" itemProp="logo url" alt="The Beet." title="The Beet." data-source="logo"><img src="https://townsquare.media/site/959/files/2019/09/logo-v3.png" alt="The Beet." title="The Beet."/></a><div class="admin-bar-wrap"></div><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728a"><!-- dynamic ad --></div></div></div><nav id="site-menu" class="hide-overflow"><div class="wrapper"><ul class="links"><li class="hassub"><a href="/category/news/" title="News" data-source="nav">News</a></li><li class="hassub"><a href="/category/recipes/" title="Recipes" data-source="nav">Recipes</a><ul class="links submenu"><li class="hassub"><a href="/tags/vegan-breakfast/" title="Breakfast" data-source="nav">Breakfast</a></li><li class="hassub"><a href="/tags/vegan-lunch/" title="Lunch" data-source="nav">Lunch</a></li><li class="hassub"><a href="/tags/snack/" title="Snack" data-source="nav">Snack</a></li><li class="hassub"><a href="/tags/dinner/" title="Dinner" data-source="nav">Dinner</a></li><li class="hassub"><a href="/tags/vegan-dessert/" title="Dessert" data-source="nav">Dessert</a></li><li class="hassub"><a href="/tags/holiday-recipes/" title="Holiday" data-source="nav">Holiday</a></li></ul></li><li class="hassub"><a href="/category/product-reviews/" title="Product Reviews" data-source="nav">Product Reviews</a></li><li class="hassub"><a href="/category/find-vegan-near-me/" title="Find Vegan Near Me" data-source="nav">Find Vegan Near Me</a><ul class="links submenu"><li class="hassub"><a href="/category/shopping-guides/" title="Shopping Guides" data-source="nav">Shopping Guides</a></li><li class="hassub"><a href="/category/city-guides/" title="City Guides" data-source="nav">City Guides</a></li><li class="hassub"><a href="/category/find-vegan-near-me/" title="HappyCow" data-source="nav">HappyCow</a></li></ul></li><li class="hassub"><a href="/category/health-nutrition/" title="Health &amp; Nutrition" data-source="nav">Health &amp; Nutrition</a><ul class="links submenu"><li class="hassub"><a href="/category/ask-the-expert/" title="Ask the Expert" data-source="nav">Ask the Expert</a></li><li class="hassub"><a href="/category/diet-weightloss/" title="Diet &amp; Weightloss" data-source="nav">Diet &amp; Weightloss</a></li><li class="hassub"><a href="/category/wellbeing-fitness/" title="Wellbeing &amp; Fitness" data-source="nav">Wellbeing &amp; Fitness</a></li></ul></li><li class="hassub"><a href="/category/getting-started/" title="Getting Started" data-source="nav">Getting Started</a><ul class="links submenu"><li class="hassub"><a href="/beginners-guide-to-going-plant-based-7-easy-steps-from-a-nutritionist/" title="The Beginner’s Guide to Going Plant-Based" data-source="nav">The Beginner’s Guide to Going Plant-Based</a></li><li class="hassub"><a href="/21-day-plant-based-challenge/" title="21 Day Plant-Based Challenge" data-source="nav">21 Day Plant-Based Challenge</a></li><li class="hassub"><a href="/2-week-clean-eating-plan/" title="Your 2 Week Clean Eating Plan" data-source="nav">Your 2 Week Clean Eating Plan</a></li><li class="hassub"><a href="/sign-up-for-your-smoothie-of-the-day-each-has-immune-boosting-properties/" title="Smoothie of the Day" data-source="nav">Smoothie of the Day</a></li></ul></li><li class="hassub"><a href="/category/community/" title="Community" data-source="nav">Community</a><ul class="links submenu"><li class="hassub"><a href="/tags/vegans-of-color/" title="Vegans of Color" data-source="nav">Vegans of Color</a></li><li class="hassub"><a href="/meet-the-team" title="Meet the Team" data-source="nav">Meet the Team</a></li></ul></li><li class="hassub"><a href="/category/lifestyle-culture/" title="Lifestyle &amp; Culture" data-source="nav">Lifestyle &amp; Culture</a></li><li class="hassub"><a href="/category/environment/" title="Environment" data-source="nav">Environment</a></li><li class="hassub"><a href="/category/on-the-beet-with-jermaine-dupri/" title="On The Beet With Jermaine Dupri" data-source="nav">On The Beet With Jermaine Dupri</a></li><li class="hidden-menu hassub hide"><a class="more-icon" href="#">More</a><ul class="links submenu"><li class="hassub hide"><a href="/category/news/" title="News" data-source="nav">News</a></li><li class="hassub hide"><a href="/category/recipes/" title="Recipes" data-source="nav">Recipes</a><ul class="links submenu"><li class="hassub"><a href="/tags/vegan-breakfast/" title="Breakfast" data-source="nav">Breakfast</a></li><li class="hassub"><a href="/tags/vegan-lunch/" title="Lunch" data-source="nav">Lunch</a></li><li class="hassub"><a href="/tags/snack/" title="Snack" data-source="nav">Snack</a></li><li class="hassub"><a href="/tags/dinner/" title="Dinner" data-source="nav">Dinner</a></li><li class="hassub"><a href="/tags/vegan-dessert/" title="Dessert" data-source="nav">Dessert</a></li><li class="hassub"><a href="/tags/holiday-recipes/" title="Holiday" data-source="nav">Holiday</a></li></ul></li><li class="hassub hide"><a href="/category/product-reviews/" title="Product Reviews" data-source="nav">Product Reviews</a></li><li class="hassub hide"><a href="/category/find-vegan-near-me/" title="Find Vegan Near Me" data-source="nav">Find Vegan Near Me</a><ul class="links submenu"><li class="hassub"><a href="/category/shopping-guides/" title="Shopping Guides" data-source="nav">Shopping Guides</a></li><li class="hassub"><a href="/category/city-guides/" title="City Guides" data-source="nav">City Guides</a></li><li class="hassub"><a href="/category/find-vegan-near-me/" title="HappyCow" data-source="nav">HappyCow</a></li></ul></li><li class="hassub hide"><a href="/category/health-nutrition/" title="Health &amp; Nutrition" data-source="nav">Health &amp; Nutrition</a><ul class="links submenu"><li class="hassub"><a href="/category/ask-the-expert/" title="Ask the Expert" data-source="nav">Ask the Expert</a></li><li class="hassub"><a href="/category/diet-weightloss/" title="Diet &amp; Weightloss" data-source="nav">Diet &amp; Weightloss</a></li><li class="hassub"><a href="/category/wellbeing-fitness/" title="Wellbeing &amp; Fitness" data-source="nav">Wellbeing &amp; Fitness</a></li></ul></li><li class="hassub hide"><a href="/category/getting-started/" title="Getting Started" data-source="nav">Getting Started</a><ul class="links submenu"><li class="hassub"><a href="/beginners-guide-to-going-plant-based-7-easy-steps-from-a-nutritionist/" title="The Beginner’s Guide to Going Plant-Based" data-source="nav">The Beginner’s Guide to Going Plant-Based</a></li><li class="hassub"><a href="/21-day-plant-based-challenge/" title="21 Day Plant-Based Challenge" data-source="nav">21 Day Plant-Based Challenge</a></li><li class="hassub"><a href="/2-week-clean-eating-plan/" title="Your 2 Week Clean Eating Plan" data-source="nav">Your 2 Week Clean Eating Plan</a></li><li class="hassub"><a href="/sign-up-for-your-smoothie-of-the-day-each-has-immune-boosting-properties/" title="Smoothie of the Day" data-source="nav">Smoothie of the Day</a></li></ul></li><li class="hassub hide"><a href="/category/community/" title="Community" data-source="nav">Community</a><ul class="links submenu"><li class="hassub"><a href="/tags/vegans-of-color/" title="Vegans of Color" data-source="nav">Vegans of Color</a></li><li class="hassub"><a href="/meet-the-team" title="Meet the Team" data-source="nav">Meet the Team</a></li></ul></li><li class="hassub hide"><a href="/category/lifestyle-culture/" title="Lifestyle &amp; Culture" data-source="nav">Lifestyle &amp; Culture</a></li><li class="hassub hide"><a href="/category/environment/" title="Environment" data-source="nav">Environment</a></li><li class="hassub hide"><a href="/category/on-the-beet-with-jermaine-dupri/" title="On The Beet With Jermaine Dupri" data-source="nav">On The Beet With Jermaine Dupri</a></li></ul></li></ul><div class="site-menu-right"><ul class="social-links"><li class="social"><a class="share-link instagram" href="https://www.instagram.com/thebeet" target="_blank" data-social="instagram"><span class="icon-base icon-instagram"></span></a></li><li class="social"><a class="share-link twitter" href="https://twitter.com/thebeetofficial" target="_blank" data-social="twitter"><span class="icon-base icon-twitter"></span></a></li><li class="social"><a class="share-link youtube" href="https://youtube.com/channel/UCHTbS6R7cdsZZUUqIJarx7Q" target="_blank" data-social="youtube"><span class="icon-base icon-youtube"></span></a></li><li class="social"><a class="share-link facebook" href="https://www.facebook.com/thebeetofficial/" target="_blank" data-social="facebook"><span class="icon-base icon-facebook"></span></a></li><ul class="social-subscriptions"><li class="sub-instagram "><a href="https://www.instagram.com/thebeet" target="_blank">INSTAGRAM</a></li><li class="share_link_small youtube sub-youtube"></li><li class="sub-facebook"></li><li class="sub-twitter"></li></ul></ul><div id="search-form" class=""><div class="form-wrap"></div><div class="icon-base icon-search"></div></div></div><div class="site-screen select-none"></div></div></nav></div></div><div id="container" class=""><div id="top-not-ads" class=""><div id="tsm-ad-1x1-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-oop"><!-- dynamic ad --></div></div></div></div><div class="tsm-ad tsm-ad-nav-970"><div id="tsm-ad-970a"><!-- dynamic ad --></div></div><div class="container-inner"><div class="site-content clearfix"><div class="main-content"><div class="wrapper post-wrapper"><div class="internal-header outgrow " style="max-height:0px"></div><div class="post clearfix"><div class="entry"><article id="post-53252" data-location="/tom-bradys-tb12-brand-launches-podcast-on-holistic-health/" data-index="0" class=""><div class="page-header"><div class="content-header show-ui front" id="content-header-53252"><div class="content-header-header"><div class="react-parallax "><div class="react-parallax-background-children" data-bottom-top="transform:translate3d(0,-20%,0);" data-top-bottom="transform:translate3d(0,20%,0);"><figure class="frameme img-tag frame-loaded"><div class="theframe" data-image="//townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg" rel="" title="" style="background-image:url(&quot;//townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg?w=980&amp;q=75&quot;)"></div></figure></div><div class="react-parallax-content"><figure class="frameme img-tag"><div class="theframe" data-image="//townsquare.media/site/959/files/2021/01/GettyImages-1168968407.jpg" rel="" title=""></div></figure></div></div><div class="header"><section class="title "><h1 class="">Tom Brady’s TB12 Launches Podcast on Peak Performance and Healthy Lifestyle</h1></section><div class="byline"><div class="authors"><address class="author"><div class="author-image icon-user"><figure class="frameme"><a class="theframe" data-image="//townsquare.media/wp-content/uploads/2012/10/profile.png" href="//thebeet.com/author/maxwellrabb/" rel="author" title="Maxwell Rabb"></a></figure></div><a class="author-name" href="//thebeet.com/author/maxwellrabb/" rel="author" title="Maxwell Rabb">Maxwell Rabb</a></address></div><time dateTime="2021-01-12 17:05:27 +0000">Published: January 12, 2021</time></div><figcaption title="Getty Images">Getty Images</figcaption></div></div></div></div><div class="content-wrap"><div class="content"><div class="pod-content"><p>Tom Brady has proved to the world&#xA0;as he plays his 21st season as the oldest QB in the league that a plant-based diet is great for longevity, strength, and endurance. Some people can barely believe that Tom Brady has achieved&#xA0;six champion rings and is still going strong on a mostly plant-based diet.</p><p>Over the years he and his&#xA0;business partner and body coach, Alex Guerrero have evolved their strategies into TB12, the company that offers plant-based protein powder, recovery drinks, and other performance fuel, as well as one best-selling book and a host of other equipment to help athletes inspired by Brady&apos;s success reach their owner personal best. Now they are adding to this content and product suite a new way to connect and learn from the master: TB12&apos;s podcast&#xA0;called <em>The&#xA0;Keep Going Podcast</em>&#xA0;is launching today, hosted by TB12 CEO John Burns. The&#xA0;show will promote the company&#x2019;s messaging around a holistic approach to health for athletes and everyday desk jockeys alike.&#xA0; The episodes&#xA0;feature conversations about healthy dietary options that do not revolve around meat and dairy and will showcase&#xA0;athletes and&#xA0;health and nutrition&#xA0;experts who share a passion for longevity and how to best live an&#xA0;active, healthy lifestyle.</p><div class="in-article-oop-container"><div class="tsm-ad tsm-ad-oop"><div id="tsm-ad-in-article-oop-1"><!-- dynamic ad --></div></div><div class="tsm-ad tsm-ad-1x1 tsm-ad-oop"><div id="tsm-ad-in-article-pixel-1"><!-- dynamic ad --></div></div></div><div class="lazyload-placeholder oembed-lazyload-placeholder" data-pod="{&quot;provider_name&quot;:&quot;provider_unknown&quot;,&quot;html&quot;:&quot;&lt;iframe src=\&quot;https://www.facebook.com/plugins/video.php?height=476&amp;amp;href=https%3A%2F%2Fwww.facebook.com%2FTB12sports%2Fvideos%2F1538212816373846%2F&amp;amp;show_text=false&amp;amp;width=380\&quot; width=\&quot;380\&quot; height=\&quot;476\&quot; frameborder=\&quot;0\&quot; scrolling=\&quot;no\&quot; style=\&quot;border: none; overflow: hidden;\&quot; wmode=\&quot;opaque\&quot;&gt;&lt;/iframe&gt;&quot;}"></div><p>The&#xA0;audio show&#xA0;focuses on&#xA0;the intersection&#xA0;of sports, health, plant-based lifestyle choices and&#xA0;of course how you can use all the TB12&#xA0;products to reach your performance and wellness&#xA0;goals.&#xA0;Tune into the <em><a href="https://tb12sports.com/blog/keep-going-podcast">Keep Going</a></em> podcast with John Burns and guests, starting&#xA0;today&#xA0;<em>on Spotify or <a href="https://podcasts.apple.com/us/podcast/the-keep-going-podcast-powered-by-tb12/id1547016275">Apple Music</a>.</em></p></div></div><div class="social-share smallandsubtle"><div class="social-bar social-icons"><ul><li><a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fthebeet.com%2Ftom-bradys-tb12-brand-launches-podcast-on-holistic-health%2F%3Ftrackback%3Dfbshare_mobile" title="Share on Facebook" target="_blank"><span class=" social-icon icon-facebook fb"><span class="share-title">Share on Facebook</span></span></a></li><li><a href="http://twitter.com/intent/tweet?text=Tom%20Brady%E2%80%99s%20TB12%20Launches%20Podcast%20on%20Peak%20Performance%20and%20Healthy%20Lifestyle%20http%3A%2F%2Fthebeet.com%2Ftom-bradys-tb12-brand-launches-podcast-on-holistic-health%2F%3Ftrackback%3Dtwitter_mobile%20%40thebeetofficial" title="Share on Twitter" target="_blank"><span class=" social-icon icon-twitter tw"><span class="share-title">Share on Twitter</span></span></a></li><li><a href="javascript:window.print();" title="Print this page"><span class=" social-icon icon-print print"><span class="share-title">Print this page</span></span></a></li></ul></div></div><div class="content-footer"><div class="tags-lines"><div class="wrapper"><span>Filed Under<!-- -->: </span><span><a href="//thebeet.com/tags/plant-based-athletes/">Plant-Based Athletes</a></span></div><div class="wrapper"><span>Categories<!-- -->: </span><span><a href="//thebeet.com/category/news/">News</a></span></div></div><div class="comments-wrapper"><div class="comments"><div><i>Comments</i><span class="icon-triangle-down"></span></div><div class="cto">Leave A Comment</div></div></div><div class="goto-top-container outgrow"><a class="goto-top icon-triangle-left" href="javascript:void(0);" title="Go To Top" data-index="0">Back To Top</a></div></div></div></article></div></div></div></div><aside class="main-aside"><div class="aside-inside"><section class="sidebar-section widget-fix_sidebar_marker" id="fix_sidebar_marker-3"><div class="wrapper clearfix"><div class="fix_sidebar_marker"></div></div></section><section class="sidebar-section widget-ts_blogroll" id="ts_blogroll-14"><header><h2><span class="title-container">Latest Featured News</span></h2></header><div class="wrapper clearfix"><section id="ts_blogroll-14" class="blogroll carousel slider dl align-right"><div class="slider blogroll-items"><div class="sizer"></div><div class="mover slide"><article class="item title-over-image"><figure class="frameme"><a class="theframe" data-image="//townsquare.media/site/959/files/2021/01/Laird_Kauai_1-1.jpg" href="//thebeet.com/morning-ritual-to-start-your-day-calm-and-stay-well-try-this-exercise/" rel="" title="Morning Ritual: To Start Your Day Calm and Stay Well, Try This Mindful Exercise" data-source="blogroll"></a><div class="loadinganim showbox" id="0"><div class="loader" style="width:30px;height:30px"><svg class="circular" viewBox="25 25 50 50" style="width:30px;height:30px"><circle class="path" cx="50" cy="50" r="20" fill="none" stroke-width="4" stroke-miterlimit="10"></circle></svg></div></div></figure><div class="content"><a href="//thebeet.com/morning-ritual-to-start-your-day-calm-and-stay-well-try-this-exercise/" title="Morning Ritual: To Start Your Day Calm and Stay Well, Try This Mindful Exer…" class="title" data-source="blogroll">Morning Ritual: To Start Your Day Calm and Stay Well, Try This Mindful Exer…</a></div></article></div><div class="previous icon-arrow-thin-left arrow icon-base round always-visible" title="Previous"></div><div class="next icon-arrow-thin-right arrow icon-base round always-visible" title="Next"></div></div></section></div></section><section class="sidebar-section widget-google-ads-widget" id="google-ads-widget-23"><div class="wrapper clearfix"><div class="widget-content"><div class="tsm-ad tsm-ad-300"><div id="tsm-ad-300a"><!-- dynamic ad --></div></div></div></div></section><section class="sidebar-section widget-tsq_sailthru_newsletter_widget" id="tsq_sailthru_newsletter_widget-7"><div class="wrapper clearfix"><div class="widget-content"></div></div></section><section class="sidebar-section widget-text" id="text-3"><header><h2><span class="title-container">Follow Us on Instagram</span></h2></header><div class="wrapper clearfix"><div class="widget-content"><div class="text-widget-inner"><!-- LightWidget WIDGET --><script src="https://cdn.lightwidget.com/widgets/lightwidget.js"></script><iframe src="https://cdn.lightwidget.com/widgets/0f6aa0fbc1105073a444c7e3e2b815c6.html" scrolling="no" allowtransparency="true" class="lightwidget-widget" style="width:100%;border:0;overflow:hidden;"></iframe></div></div></div></section></div></aside></div><section class="site-footer"><footer><div class="links clearfix"><div class="logo"></div><div class="details"><h2>Information</h2><ul><li class=""><a title="About" href="/welcome-to-the-beet/" aria-label="About" class="">About</a></li><li class=""><a title="Meet the Team" href="/meet-the-team" aria-label="Meet the Team" class="">Meet the Team</a></li><li class=""><a title="Contact" href="/contact" aria-label="Contact" class="">Contact</a></li><li class=""><a title="Contest Rules" href="/giveaways-rules" aria-label="Contest Rules" class="">Contest Rules</a></li><li class=""><a title="Report an Inaccuracy" href="/report-an-inaccuracy-or-content-problem" aria-label="Report an Inaccuracy" class="">Report an Inaccuracy</a></li><li class=""><a title="Privacy" href="/privacy-policy" aria-label="Privacy" class="">Privacy</a></li><li class=""><a title="Terms" href="/terms-and-conditions" aria-label="Terms" class="">Terms</a></li></ul></div><div class="social-links"><h2>Follow Us</h2><ul><li class="social"><a class="share_link instagram" href="https://www.instagram.com/thebeet" target="_blank" data-social="instagram"><span class="icon-instagram"></span></a></li><li class="social"><a class="share_link youtube" href="https://www.youtube.com/channel/UCHTbS6R7cdsZZUUqIJarx7Q" target="_blank" data-social="youtube"><span class="icon-youtube"></span></a></li><li class="social"><a class="share_link twitter" href="https://twitter.com/thebeetofficial" target="_blank" data-social="twitter"><span class="icon-twitter"></span></a></li><li class="social"><a class="share_link facebook" href="https://www.facebook.com/thebeetofficial/" target="_blank" data-social="facebook"><span class="icon-facebook"></span></a></li></ul></div></div><div class="legal">2021<!-- --> <!-- -->The Beet.<!-- -->, <a href="http://www.townsquaremedia.com">Townsquare Media</a>, Inc. All rights reserved.</div></footer></section></div><section class="bottom-components"><div id="bottom-not-ads"><div class="tsm-ad tsm-ad-728"><div id="tsm-ad-728b"><!-- dynamic ad --></div></div></div></section></div></div></div>
          <script style="display: none;">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</script>
          <script>(function(d){
            var getFile = window.TSM.fn.getFile;
            if(!window.TSM.fn.isIe(navigator.userAgent)){
              try{
                eval('(async function(){var dependencies = ["//townsquare.media/public/dist/desktop/main.bundle.506a1ae6887e6e598b04eb8cd1d8514706ac2c03.js?mver=764"];for(var i=0;i<dependencies.length;i++){await getFile( dependencies[i] );}})();');
              }catch(e){console.error(e);}
            }else{
              document.write('<scr'+'ipt src="//townsquare.media/public/scripts.min.js?ver=506a1ae6887e6e598b04eb8cd1d8514706ac2c03&mver=764"></sc'+'ript>');
            }
          })(document);</script>
          
        </body>
      </html>